Incomplete Google Play financial reports
Incident Report for Appfigures
Resolved
Google has regenerated financial reports dating back to February with updated SKU information. We've re-imported these reports for available accounts, reports should be as up to date as possible.
Posted Jun 20, 2017 - 10:21 EDT
Update
Google is still in the process of resolving this issue, so for now we're still seeing incomplete data.

When Google resolves the issue and updates April's report we'll automatically re-sync it so your reports will be up to date.
Posted May 01, 2017 - 10:35 EDT
Monitoring
We've been getting reports about financial reports not matching up with the Google Play Developer Console dating back to February. Upon closer investigation, SKUs for a majority of rows are missing within those raw reports. Google has implied the reports will be updated in a few weeks. Once new reports are released, we'll re-import for available accounts.
Posted Apr 11, 2017 - 16:17 EDT