Apple Sales Report Delays
Incident Report for Appfigures
Resolved
We've rolled out multiple updates over the last few days that speed up and fortify the sync process, making syncs behave as expected. If something is still missing please contact us directly.
Posted Feb 17, 2017 - 18:48 EST
Monitoring
We've rolled out a workaround that seems to eliminate the delays and is currently catching everyone up to the latest reports.

We're continuing to monitor the process and will set to Resolved once we've seen enough accounts syncing as expected.
Posted Feb 06, 2017 - 13:57 EST
Identified
Usage and Sales reports may be delayed due to networking issues with iTunes Connect.
Posted Feb 05, 2017 - 23:51 EST