iTunes Connect planned down time on 4/21
Incident Report for Appfigures
Resolved
Apple's planned down time has ended. Linking accounts and syncing should once again be back to normal.
Posted Apr 23, 2018 - 14:45 EDT
Monitoring
Apple announced that iTunes Connect will be unavailable on April 21st beginning at 7am PST for up to eight hours. Linking and syncing accounts should be successful though we'll keep an eye on everything!
Posted Apr 20, 2018 - 19:27 EDT