Slow running syncs
Incident Report for Appfigures
Resolved
This incident has been resolved.
Posted Apr 14, 2018 - 08:38 EDT
Identified
We've identified an issue causing slow syncs across Apple, Google Play, and Amazon. This slowdown is also causing a delay for email reports and alerts. We're working to get back up to speed.
Posted Apr 13, 2018 - 12:34 EDT