Apple isn't updating reviews
Incident Report for Appfigures
Resolved
Reviews are back up to speed on Apple's end and are be pulling in smoothly.
Posted Feb 24, 2017 - 10:58 EST
Monitoring
We've noticed reviews for iOS apps have stopped appearing in iTunes for all apps after 2/14. We've reached out to Apple and will update when reviews start showing up again.

Note: Our reviews engine is running normally, so when reviews come back they'll be imported automatically.
Posted Feb 17, 2017 - 18:35 EST